Required. The commit to use as the basis for the comparison.
Required. The commit to compare against the base commit.
Language

News entries

No news entry changes

New packages

NameVersion
go-std1.16.15More information
go-std1.17.9More information
go-std1.14.15More information

Removed packages

NameVersion
texlive-stmaryrd-fixed59745More information
texlive-psnfss-fixed59745More information
polkit0.121More information
texlive-amsfonts-fixed59745More information
texlive-babel-fixed59745More information

Version changes

NameVersions
polkit-duktape
wayland
go-golang-org-x-sys
python-idna
python-urllib3
python-certifi
python2-pycparser
bubblewrap
python-pycparser
esbuild
go
mesa-opencl
python-cryptography
python-cryptography-vectors
perl-net-ssleay
kaldi
man-db
mesa-headers
python-pytz
openblas-ilp64
postgresql
ucd
tzdata
extra-cmake-modules
docbook-sgml
python-iso8601
python-flaky
python-chardet
python-charset-normalizer
python-pyopenssl
imlib2
openfst
openblas
mesa
python-requests
mesa-opencl-icd

Lint warnings

extra-cmake-modules (version: 5.70.0)

LinterMessage
Resolved warningformatting

Look for formatting issues in the source

line 122 is way too long (91 characters)

extra-cmake-modules (version: 5.91.0)

LinterMessage
New warningformatting

Look for formatting issues in the source

line 128 is way too long (92 characters)
New warningformatting

Look for formatting issues in the source

line 129 is way too long (107 characters)
New warningformatting

Look for formatting issues in the source

line 142 is way too long (92 characters)

imlib2 (version: 1.7.1)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'pkgconfig' does not match package name 'pkg-config'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libjpeg' does not match package name 'libjpeg-turbo'

maven-wagon-provider-api (version: 3.4.3)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/4sh39d6c45snp8wp0jbnng57lhx3f1fg-maven-wagon-provider-api-3.4.3 and /gnu/store/f817pfrl21v8q2398y1zz9g6w6n90a03-maven-wagon-provider-api-3.4.3 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/d04y4sr3ibjbaapijhac3x35si7ik7kn-maven-wagon-provider-api-3.4.3 and /gnu/store/bi1y5dx0pz68bs87283iq9mqcr1xh4af-maven-wagon-provider-api-3.4.3 collide

mesa (version: 21.3.2)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'gettext' does not match package name 'gettext-minimal'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'python' does not match package name 'python-wrapper'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libelf' does not match package name 'elfutils'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libva' does not match package name 'libva-without-mesa'

mesa-opencl (version: 21.3.2)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'gettext' does not match package name 'gettext-minimal'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'python' does not match package name 'python-wrapper'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libelf' does not match package name 'elfutils'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libva' does not match package name 'libva-without-mesa'

mesa-opencl-icd (version: 21.3.2)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'python' does not match package name 'python-wrapper'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'gettext' does not match package name 'gettext-minimal'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libelf' does not match package name 'elfutils'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libva' does not match package name 'libva-without-mesa'

nototools (version: 0.2.16)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 and /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 and /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 collide

openblas (version: 0.3.18)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'fortran' does not match package name 'gfortran'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'fortran-lib' does not match package name 'gfortran:lib'

openblas (version: 0.3.20)

LinterMessage
New warninginput-labels

Identify input labels that do not match package names

label 'gfortran' does not match package name 'gfortran:lib'

openblas-ilp64 (version: 0.3.18)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'fortran-lib' does not match package name 'gfortran:lib'
Resolved warninginput-labels

Identify input labels that do not match package names

label 'fortran' does not match package name 'gfortran'

openblas-ilp64 (version: 0.3.20)

LinterMessage
New warninginput-labels

Identify input labels that do not match package names

label 'gfortran' does not match package name 'gfortran:lib'

polkit (version: 0.120)

LinterMessage
New warninginput-labels

Identify input labels that do not match package names

label 'glib' does not match package name 'glib:bin'

polkit-duktape (version: 0.120)

LinterMessage
New warninginput-labels

Identify input labels that do not match package names

label 'glib' does not match package name 'glib:bin'

postgresql (version: 13.4)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libuuid' does not match package name 'util-linux:lib'

postgresql (version: 10.20)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libuuid' does not match package name 'util-linux:lib'
New warninginput-labels

Identify input labels that do not match package names

label 'util-linux' does not match package name 'util-linux:lib'

postgresql (version: 11.15)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libuuid' does not match package name 'util-linux:lib'
New warninginput-labels

Identify input labels that do not match package names

label 'util-linux' does not match package name 'util-linux:lib'

postgresql (version: 13.6)

LinterMessage
New warninginput-labels

Identify input labels that do not match package names

label 'util-linux' does not match package name 'util-linux:lib'

postgresql (version: 14.2)

LinterMessage
Resolved warninginput-labels

Identify input labels that do not match package names

label 'libuuid' does not match package name 'util-linux:lib'
New warninginput-labels

Identify input labels that do not match package names

label 'util-linux' does not match package name 'util-linux:lib'

python-afdko (version: 3.8.1)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 and /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 and /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 collide

python-chardet (version: 4.0.0)

LinterMessage
New warningoptional-tests

Make sure tests are only run when requested

the 'check' phase should respect #:tests?
New warningwrapper-inputs

Make sure 'wrap-program' can finds its interpreter.

"bash-minimal" should be in 'inputs' when 'wrap-program' is used

python-charset-normalizer (version: 2.0.11)

LinterMessage
New warningwrapper-inputs

Make sure 'wrap-program' can finds its interpreter.

"bash-minimal" should be in 'inputs' when 'wrap-program' is used

python-cu2qu (version: 1.6.7.post1)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 and /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 and /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 collide

python-defcon-bootstrap (version: 0.10.0)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 and /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 and /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 collide

python-fontparts (version: 0.10.4)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 and /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 and /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 collide

python-fonttools (version: 4.28.5)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 and /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 and /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 collide

python-mutatormath (version: 3.0.1)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 and /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 and /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 collide

python-pyopenssl (version: 21.0.0)

LinterMessage
New warningpatch-file-names

Validate file names and availability of patches

file names of patches should start with the package name

python-sfdlib (version: 1.2.3)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 and /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 and /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 collide

python-ufo2ft (version: 2.26.0)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 and /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 and /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 collide

python-ufolib2 (version: 0.13.1)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 and /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 and /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 collide

python-ufoprocessor (version: 1.9.0)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 and /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 and /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 collide

texlive-amsfonts (version: 59745)

LinterMessage
Resolved warningformatting

Look for formatting issues in the source

line 1542 is way too long (91 characters)
Resolved warningformatting

Look for formatting issues in the source

line 1515 is way too long (94 characters)
Resolved warningformatting

Look for formatting issues in the source

line 1540 is way too long (93 characters)

texlive-stmaryrd (version: 59745)

LinterMessage
New warningformatting

Look for formatting issues in the source

line 6859 is way too long (98 characters)

tryton (version: 6.0.5)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/frcwbha85bkhqmzdk78xmslh1rzayxsg-librsvg-2.50.7 and /gnu/store/q3vymxinnp6cxqq1cpz1rdqmnwq5x1ni-librsvg-2.50.7 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/g30spl4av6vibq4bdv9fqdrs9ghb4fjs-librsvg-2.50.7 and /gnu/store/affqm67szy7m9alhsvx7561z2va8xdn4-librsvg-2.50.7 collide

weasyprint (version: 54.3)

LinterMessage
Resolved warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/cfjaks4hdqqqh7wzwn6rknrxnhqd578l-python-fonttools-4.28.5 and /gnu/store/xl56mn2b5z2hb4labiz58wlcrbskmqrs-python-fonttools-4.28.5 collide
New warningprofile-collisions

Report collisions that would occur due to propagated inputs

propagated inputs /gnu/store/zlg7s86frmvbyf27627h0lgy54lwrkl9-python-fonttools-4.28.5 and /gnu/store/zlarcyaijrc2ayam03pjsvp5kkfnalzn-python-fonttools-4.28.5 collide