Job 30092

Return at most this many characters.
Start reading the log from this character.
debug: Starting computing the channel derivation
debug: using open-inferior
debug: Acquiring advisory session lock: latest-channel-instances
guix repl: warning: 'nix-protocol-error?' is deprecated, use 'store-protocol-error?' instead
guix repl: warning: 'nix-protocol-error-message' is deprecated, use 'store-protocol-error-message' instead
debug: Finished aquiring lock latest-channel-instances, took 0 seconds
Updating channel 'guix' from Git repository at 'https://git.savannah.gnu.org/git/guix.git'...
Authenticating channel 'guix', commits 9edb3f6 to 1741072 (2 new commits)...

[#######################################                                       ]
Backtrace:
In ice-9/boot-9.scm:
  1752:10 19 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix-data-service/jobs/load-new-guix-revision.scm:
  1204:15 18 (start-inferior-and-return-derivation-file-names)
In ice-9/boot-9.scm:
  1752:10 17 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix-data-service/jobs/load-new-guix-revision.scm:
   350:21 16 (_)
  1209:20 15 (_)
In guix/channels.scm:
    502:7 14 (loop _ _)
In guix/combinators.scm:
    48:26 13 (fold2 #<procedure 7ff3d82b3de0 at guix/channels.scm:502:13 (channel previous-channels instances)> _ _ (#<<channel> name: guix url: "https://git.savannah.gnu.org/git/guix.git" branch: "master" commit: "1741072bba6bca41dfd7f7341cfeefc7786c…>))
In guix/channels.scm:
   512:29 12 (_ #<<channel> name: guix url: "https://git.savannah.gnu.org/git/guix.git" branch: "master" commit: "1741072bba6bca41dfd7f7341cfeefc7786c160a" introduction: #f location: ((filename . "guix-data-service/jobs/load-new-guix-revision.scm") (l…> …)
   400:12 11 (latest-channel-instance #<store-connection 256.99 7ff3d824b1e0> _ #:patches _ #:starting-commit _ #:authenticate? _ #:validate-pull _)
In guix/git.scm:
    290:7 10 (call-with-repository _ _)
In guix/git-authenticate.scm:
   442:22  9 (authenticate-repository #<git-repository 2489f70> _ _ #:keyring-reference _ #:cache-key _ #:end _ #:authentic-commits _ #:historical-authorizations _ #:make-reporter _)
In guix/progress.scm:
    71:36  8 (call-with-progress-reporter _ _)
In srfi/srfi-1.scm:
   460:18  7 (fold #<procedure 7ff3e0136600 at guix/git-authenticate.scm:288:8 (commit stats)> _ _)
In guix/git-authenticate.scm:
   290:24  6 (_ #<git-commit 39465409f0481f27d252ce25d2b02d3f5cbc6723> ((#<<openpgp-public-key> version: 4 subkey?: #t time: 1500771224 value: #<canonical-sexp 7ff3d9539710 | 248c760> fingerprint: #vu8(245 218 32 50 75 135 61 11 122 56 118 114 13…> . 1)))
    237:4  5 (authenticate-commit _ _ _ #:default-authorizations _)
In ice-9/boot-9.scm:
  1685:16  4 (raise-exception _ #:continuable? _)
  1685:16  3 (raise-exception _ #:continuable? _)
  1780:13  2 (_ #<&compound-exception components: (#<&unauthorized-commit-error commit: #<oid 39465409f0481f27d252ce25d2b02d3f5cbc6723> signing-key: #<<openpgp-public-key> version: 4 subkey?: #t time: 1605202040 value: #<canonical-sexp 7ff3be97cc20 | 2…>)
In guix-data-service/jobs/load-new-guix-revision.scm:
  1246:23  1 (_ %exception #<&compound-exception components: (#<&unauthorized-commit-error commit: #<oid 39465409f0481f27d252ce25d2b02d3f5cbc6723> signing-key: #<<openpgp-public-key> version: 4 subkey?: #t time: 1605202040 value: #<canonical-sexp 7ff3b…>)
In unknown file:
           0 (backtrace #<undefined>)

#<unspecified>
error: channel->derivation-file-names-by-system: %exception: (#<&compound-exception components: (#<&unauthorized-commit-error commit: #<oid 39465409f0481f27d252ce25d2b02d3f5cbc6723> signing-key: #<<openpgp-public-key> version: 4 subkey?: #t time: 1605202040 value: #<canonical-sexp 7ff3be97cc20 | 292a600> fingerprint: #vu8(40 65 154 198 80 56 116 64 199 233 47 250 34 8 210 9 88 193 222 176)>> #<&formatted-message format: "commit ~a not signed by an authorized key: ~a\n" arguments: ("39465409f0481f27d252ce25d2b02d3f5cbc6723" "2841 9AC6 5038 7440 C7E9  2FFA 2208 D209 58C1 DEB0")>)>)

debug: Finished computing the channel derivation, took 12 seconds
error: load-new-guix-revision: wrong-type-arg (for-each Wrong type argument: ~S (#f) ())

Backtrace:
          18 (primitive-load "/gnu/store/akdrnww95x123jkvljb020mrr7dayqjm-guix-data-service-0.0.1-git.1962b1f/bin/.guix-data-service-process-job-real")
In ice-9/boot-9.scm:
  1752:10 17 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix-data-service/database.scm:
    88:14 16 (_)
In guix-data-service/jobs/load-new-guix-revision.scm:
  2031:13 15 (_ #<pg-conn 23add70 (connected)>)
In guix-data-service/utils.scm:
    44:17 14 (call-with-time-logging "processing revision 1741072bba6bca41dfd7f7341cfeefc7786c160a" _)
In ice-9/boot-9.scm:
  1752:10 13 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix-data-service/database.scm:
    88:14 12 (_)
In guix-data-service/jobs/load-new-guix-revision.scm:
  1987:24 11 (_ #<pg-conn 23bf010 (connected)>)
In ice-9/boot-9.scm:
  1747:15 10 (with-exception-handler #<procedure 7ff3d8286120 at ice-9/boot-9.scm:809:2 _> _ #:unwind? _ #:unwind-for-type _)
  1752:10  9 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
  1752:10  8 (with-exception-handler _ _ #:unwind? _ #:unwind-for-type _)
In guix/store.scm:
   659:37  7 (thunk)
In guix-data-service/jobs/load-new-guix-revision.scm:
  1572:10  6 (load-new-guix-revision #<pg-conn 23add70 (connected)> #<store-connection 256.99 7ff3d824b1e0> "1" "1741072bba6bca41dfd7f7341cfeefc7786c160a")
   1263:4  5 (channel->derivations-by-system _ _ _ _)
In srfi/srfi-1.scm:
    241:2  4 (for-each _ _)
In ice-9/boot-9.scm:
  1685:16  3 (raise-exception _ #:continuable? _)
  1685:16  2 (raise-exception _ #:continuable? _)
  1780:13  1 (_ #<&compound-exception components: (#<&assertion-failure> #<&origin origin: "for-each"> #<&message message: "Wrong type argument: ~S"> #<&irritants irritants: (#f)> #<&exception-with-kind-and-args kind: wrong-type-arg args: ("for-each" "…>)
In unknown file:
           0 (backtrace #<undefined>)