Language

Package: cppawk-egawk @ 20220703

Synopsis

cppawk that calls Enhanced GNU Awk by default

Description

cppawk is a shell script that invokes the C preprocessor (cpp) on Awk code and calls Awk (by default GNU Awk) on the result.

cppawk understands the basic Awk options like -F and -v, and also understands common cpp options like -I and -Dmacro=value.

cppawk has no dependencies beyond Awk, cpp, sed and some GNU core utilities (including printf). Preprocessed programs can be captured and transferred to systems that have Awk but not cpp or cppawk.

Home page
https://www.kylheku.com/cgit/cppawk/
Location
gnu/packages/gawk.scm (line: 223, column: 2)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxxtensa-ath9k-elf/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxx86_64-linux-gnux32/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxriscv64-linux-gnu/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxpowerpc-linux-gnu/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxpowerpc64-linux-gnu/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxpowerpc64le-linux-gnu/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxor1k-elf/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxmips64el-linux-gnu/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxi686-w64-mingw32/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxi586-pc-gnu/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxavr/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxarm-linux-gnueabihf/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
x86_64-linuxaarch64-linux-gnu/gnu/store/k57r6y433q9m3skpgvldl4sd71s04hny-cppawk-egawk-20220703.drv
riscv64-linux/gnu/store/q8x0zxn3aqgcfipz7iprlkh536dnfhpw-cppawk-egawk-20220703.drv
powerpc-linux/gnu/store/1zabs0xj55w31n28dg0gmw9sqkd1c3my-cppawk-egawk-20220703.drv
    powerpc64le-linux/gnu/store/1l25j861ppny0nxxx05wzxzq1450232i-cppawk-egawk-20220703.drv
    mips64el-linux/gnu/store/fp113689qpa0jbcqab82nb59m1p0xzhd-cppawk-egawk-20220703.drv
      i686-linux/gnu/store/mgvfndxgb8z92vg1aiy5smkyrj678bw9-cppawk-egawk-20220703.drv
      i586-gnu/gnu/store/y2xxvjg7yvsmag8qwp7wywgwgpvf95ji-cppawk-egawk-20220703.drv
      armhf-linux/gnu/store/2q5739nxwml7f4gxcdh3p7k9nmrgda3m-cppawk-egawk-20220703.drv
      aarch64-linux/gnu/store/l2nrrbbrad7zdm64qxxi09wn11z6g1cj-cppawk-egawk-20220703.drv

      Lint warnings

      LinterMessageLocation
      synopsis

      Validate package synopses

      synopsis should start with an upper-case letter or digit
      synopsis

      Validate package synopses

      synopsis should start with an upper-case letter or digit