Language

Package: oath-toolkit @ 2.6.9

Synopsis

OTP components

Description

The OATH Toolkit provides various components for building OTP authentication systems:

  • oathtool, a command-line tool for generating & validating OTPs.

  • liboath, a C library for OATH handling.

  • pskctool, a command-line tool for manipulating secret key files in the PSKC format described in RFC6030.

  • libpskc, a shared and static C library for PSKC handling.

  • pam_oath, a PAM module for pluggable login authentication.

Supported technologies include the event-based HOTP algorithm (RFC4226), the time-based TOTP algorithm (RFC6238), and PSKC (RFC6030) to manage secret key data.

Home page
https://www.nongnu.org/oath-toolkit/
Location
gnu/packages/authentication.scm (line: 63, column: 2)
Licenses

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/b8rqnk2k44nb255qfivgd4i00hxkln4x-oath-toolkit-2.6.9.drv
x86_64-linuxx86_64-w64-mingw32/gnu/store/f95p00j0fd4159ambp968xraid4yxsl0-oath-toolkit-2.6.9.drv
x86_64-linuxx86_64-linux-gnux32/gnu/store/p6wklmg2zm5pd2g18dsn4b3rdvbxhdpy-oath-toolkit-2.6.9.drv
    x86_64-linuxriscv64-linux-gnu/gnu/store/ichy70ws0bi5c0g5xglaiyv1ihi16gi6-oath-toolkit-2.6.9.drv
    x86_64-linuxpowerpc-linux-gnu/gnu/store/bv41kp0cjxpiccw2daznl89a0ji62y0y-oath-toolkit-2.6.9.drv
    x86_64-linuxpowerpc64-linux-gnu/gnu/store/9xf8g90yrs4sxsy6ynqkg2959bl832ma-oath-toolkit-2.6.9.drv
      x86_64-linuxpowerpc64le-linux-gnu/gnu/store/r5zrh7x7mgmvhm0mi0rw6x84cw6mbshi-oath-toolkit-2.6.9.drv
      x86_64-linuxmips64el-linux-gnu/gnu/store/avyl92yqa32p8whvag4mrk69a5579p2c-oath-toolkit-2.6.9.drv
      x86_64-linuxi686-w64-mingw32/gnu/store/bm16g2r3z8jd1735q0pxj2z0dcac1yw0-oath-toolkit-2.6.9.drv
      x86_64-linuxi586-pc-gnu/gnu/store/nx7xn8w5cg8c8js1gw9vr2vg1nd0f7a0-oath-toolkit-2.6.9.drv
      x86_64-linuxarm-linux-gnueabihf/gnu/store/qpdgaz99r475dr5dsyw0x0bm2z270hx1-oath-toolkit-2.6.9.drv
      x86_64-linuxaarch64-linux-gnu/gnu/store/5d7491s1zqi3vikvyp1s1001l6jz1rni-oath-toolkit-2.6.9.drv
      riscv64-linux/gnu/store/ncn21mvj3cx4ffgma96qxwpzp6s9xn1i-oath-toolkit-2.6.9.drv
      powerpc-linux/gnu/store/l4gwj45wjdbrpcxazakn4qnpnh3dslpw-oath-toolkit-2.6.9.drv
        powerpc64le-linux/gnu/store/4xwndqrhaipw53is9ksrw6lk375r011m-oath-toolkit-2.6.9.drv
        mips64el-linux/gnu/store/kaym072yvf0yrgpwnv9qmqhb4rrzpvkj-oath-toolkit-2.6.9.drv
          i686-linux/gnu/store/38k3grc183havvzml4gdp0ayfcnr8zva-oath-toolkit-2.6.9.drv
          i586-gnu/gnu/store/q3mm748ihb0z6wh8mjyj7j43wbf6pqwr-oath-toolkit-2.6.9.drv
          armhf-linux/gnu/store/f20a92dsmkfp3h0zqsgcwrib4xr0b4yw-oath-toolkit-2.6.9.drv
          aarch64-linux/gnu/store/m53m1rvjd4ah1qqmm62krdq08ldiymjd-oath-toolkit-2.6.9.drv

          Lint warnings

          LinterMessageLocation
          synopsis

          Validate package synopses

          synopsis should start with an upper-case letter or digit