Language

Package: u-boot-rpi-arm64-efi @ 2024.01

Synopsis

ARM bootloader

Description

U-Boot is a bootloader used mostly for ARM boards. It also initializes the boards (RAM etc).

It allows network booting and uses the device-tree from the firmware, allowing the usage of overlays. It can act as an EFI firmware for the grub-efi-netboot-removable-bootloader. This is a common 64-bit build of U-Boot for all 64-bit capable Raspberry Pi variants.

Home page
https://www.denx.de/wiki/U-Boot/
Location
gnu/packages/bootloaders.scm (line: 996, column: 4)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/wn1af9vrn569s8g6lqz678w5nqyjsfjs-u-boot-rpi-arm64-efi-2024.01.drv
x86_64-linuxxtensa-ath9k-elf/gnu/store/hl97vvpic81y4mkrq1cp3pc0vwpmz82y-u-boot-rpi-arm64-efi-2024.01.drv
    x86_64-linuxx86_64-w64-mingw32/gnu/store/nk9604k1girh1kfgj5rmminigghjxbf8-u-boot-rpi-arm64-efi-2024.01.drv
    x86_64-linuxx86_64-linux-gnux32/gnu/store/v9r48x04j3wzqyw5mbbny9a5yyrybrmh-u-boot-rpi-arm64-efi-2024.01.drv
    x86_64-linuxriscv64-linux-gnu/gnu/store/bdinxmrfyg2wniqz1ink8kyggjz75alj-u-boot-rpi-arm64-efi-2024.01.drv
    x86_64-linuxpowerpc-linux-gnu/gnu/store/6ls3x36wvbxvxmczm8qpr0g80vh9min1-u-boot-rpi-arm64-efi-2024.01.drv
    x86_64-linuxpowerpc64-linux-gnu/gnu/store/w0afzcf7760kdy88q30fp7fbysqcm8jq-u-boot-rpi-arm64-efi-2024.01.drv
      x86_64-linuxpowerpc64le-linux-gnu/gnu/store/qi92fzym5mgw8kycc9fcl839zcvkhk32-u-boot-rpi-arm64-efi-2024.01.drv
      x86_64-linuxor1k-elf/gnu/store/cvda0mmwmsn36xr1cbbr3f3sjqc2kh7z-u-boot-rpi-arm64-efi-2024.01.drv
        x86_64-linuxmips64el-linux-gnu/gnu/store/ys0xbckj6wx7hv8lnb3xc8pqr8ab4j91-u-boot-rpi-arm64-efi-2024.01.drv
        x86_64-linuxi686-w64-mingw32/gnu/store/yq12sbh6hyfvs8x5xl9fhrlc52kwf3qm-u-boot-rpi-arm64-efi-2024.01.drv
        x86_64-linuxi586-pc-gnu/gnu/store/wmnxpk2fkx81c1n8c050v88q94c6rx4l-u-boot-rpi-arm64-efi-2024.01.drv
        x86_64-linuxavr/gnu/store/8819bpvpskdd6wm47i2kg43wrh70iviy-u-boot-rpi-arm64-efi-2024.01.drv
        x86_64-linuxarm-linux-gnueabihf/gnu/store/skymw84vwvcbrriim2y438sk7yx34ki1-u-boot-rpi-arm64-efi-2024.01.drv
        x86_64-linuxaarch64-linux-gnu/gnu/store/7s9drm7gzscsf4aqlzpx20wca6qnphzl-u-boot-rpi-arm64-efi-2024.01.drv
        riscv64-linux/gnu/store/71a55w2qnzrpnrvr3v93p12a33wz9dkg-u-boot-rpi-arm64-efi-2024.01.drv
        powerpc-linux/gnu/store/2bwgdjqh6p53dfkxyacdgnf7qrwl711j-u-boot-rpi-arm64-efi-2024.01.drv
          powerpc64le-linux/gnu/store/9972qh28qfihwp3dvxv226s6afhagqiq-u-boot-rpi-arm64-efi-2024.01.drv
          mips64el-linux/gnu/store/pvqhkyphdc8sr3nlmf8b4bq06j7ldc1i-u-boot-rpi-arm64-efi-2024.01.drv
            i686-linux/gnu/store/94dzg7hf2lvwl8hbpbwwxbi5sfch6z37-u-boot-rpi-arm64-efi-2024.01.drv
            armhf-linux/gnu/store/ff9ml44mgj1h89zx5ay81f5g7iaf8him-u-boot-rpi-arm64-efi-2024.01.drv
            aarch64-linux/gnu/store/9np8j95g35p9l30vd1pqbkws7fzhyjh9-u-boot-rpi-arm64-efi-2024.01.drv

            Lint warnings

            LinterMessageLocation
            input-labels

            Identify input labels that do not match package names

            label 'util-linux' does not match package name 'util-linux:lib'
            patch-file-names

            Validate file names and availability of patches

            file names of patches should start with the package name