Language

Package: squirrel @ 3.1

Synopsis

High level imperative, object-oriented programming language

Description

Squirrel is a high level imperative, object-oriented programming language, designed to be a light-weight scripting language that fits in the size, memory bandwidth, and real-time requirements of applications like video games.

Home page
https://squirrel-lang.org/
Location
gnu/packages/squirrel.scm (line: 31, column: 2)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/m9afzjk2r4l9q8zbgzjb8c0p7w5rq5x2-squirrel-3.1.drv
    x86_64-linuxx86_64-w64-mingw32/gnu/store/jhr614cs488qg70wmwxg3x58736s607i-squirrel-3.1.drv
    x86_64-linuxriscv64-linux-gnu/gnu/store/1rzlpjb3sbxgxkz9a19bwn9n0sx5brvh-squirrel-3.1.drv
    x86_64-linuxpowerpc-linux-gnu/gnu/store/bf70gbbh5547cnxizx196aj2m78vqaiz-squirrel-3.1.drv
    x86_64-linuxpowerpc64le-linux-gnu/gnu/store/2x9vsb7cxw03qalqnqsm4i293sx6qdwq-squirrel-3.1.drv
    x86_64-linuxmips64el-linux-gnu/gnu/store/qb7bbhi0apqz7lpyqbmhzw8yjdwdfs3n-squirrel-3.1.drv
    x86_64-linuxi686-w64-mingw32/gnu/store/sbnkzdkyc253pla2skfda3k541ivgp9a-squirrel-3.1.drv
    x86_64-linuxi586-pc-gnu/gnu/store/dxjdbprm8iysbsdydndlrfzahlcrkgq8-squirrel-3.1.drv
    x86_64-linuxarm-linux-gnueabihf/gnu/store/fa29bf0wh9wnmwpsppwfw0lhlr5cyf0j-squirrel-3.1.drv
    x86_64-linuxaarch64-linux-gnu/gnu/store/cpz93p5a4h8aqqa87acx0kd50g94ihvp-squirrel-3.1.drv
    riscv64-linux/gnu/store/kv9fpf3i2nb9y3sb1zmbz2zvml0jhphd-squirrel-3.1.drv
      powerpc-linux/gnu/store/qg5315n8s46brj47cmixa2lvidqs76kl-squirrel-3.1.drv
        powerpc64le-linux/gnu/store/fw3cmw5jy95vf6ai0pz64ag4giah0079-squirrel-3.1.drv
        mips64el-linux/gnu/store/79hp0k35vg5n7qb8qmskc6k7jsz5kzs5-squirrel-3.1.drv
          i686-linux/gnu/store/5am1jld04k758982mm6i5n05l0hpynmc-squirrel-3.1.drv
          i586-gnu/gnu/store/8vhf26h0fwj4fwfvidlnfm6f5zd951yz-squirrel-3.1.drv
          armhf-linux/gnu/store/nmjipq2r757h6qfiki09zy7p9sfg64gm-squirrel-3.1.drv
          aarch64-linux/gnu/store/fssqvvg5sbyx7s38nr4p4g5kd1zfqn2j-squirrel-3.1.drv

            Lint warnings

            LinterMessageLocation
            input-labels

            Identify input labels that do not match package names

            label 'cmake' does not match package name 'cmake-minimal'