Language

Package: openfoam @ 4.1

Synopsis

Framework for numerical simulation of fluid flow

Description

OpenFOAM provides a set of solvers and methods for tackling problems in the field of Computational Fluid Dynamics (CFD). It is written in C++. Governing equations such as the Navier-Stokes equations can be solved in integral form. Physical processes such as phase change, droplet transport and chemical reaction can be modelled. Numerical methods are included to deal with sharp gradients, such as those encountered in flows with shock waves and flows with gas/liquid interfaces. Large problems may be split into smaller, connected problems for efficient solution on parallel systems.

Home page
https://openfoam.org
Location
gnu/packages/simulation.scm (line: 61, column: 2)
License

Derivations

SystemTargetDerivationBuild status
x86_64-linux/gnu/store/ajvblbma5wsb86fh2nvi9jzp0sk30wgh-openfoam-4.1.drv

    Lint warnings

    LinterMessageLocation
    formatting

    Look for formatting issues in the source

    line 130 is way too long (109 characters)
    formatting

    Look for formatting issues in the source

    line 144 is way too long (91 characters)
    inputs-should-be-native

    Identify inputs that should be native inputs

    'flex' should probably be a native input
    derivation

    Report failure to compile a package to a derivation

    failed to create x86_64-linux derivation: path ‘/gnu/store/gfvmiyi8y176i6x8icrl42mblqz79n2j-gnuplot-5.2.7.drv’ is not valid
    derivation

    Report failure to compile a package to a derivation

    failed to create i686-linux derivation: path ‘/gnu/store/imq41gd3q2767il9gq6mqh5cv44x09rf-guile-2.2.6.drv’ is not valid
    derivation

    Report failure to compile a package to a derivation

    failed to create armhf-linux derivation: path ‘/gnu/store/132aqp4qjfys7abpr30jklkd33dl5lc1-patch-2.7.6.drv’ is not valid
    derivation

    Report failure to compile a package to a derivation

    failed to create aarch64-linux derivation: path ‘/gnu/store/0afbxr7962z9ci6kw840n088qsmyz8lr-guile-2.2.6.drv’ is not valid
    derivation

    Report failure to compile a package to a derivation

    failed to create mips64el-linux derivation: path ‘/gnu/store/jmxqjk7ihjszafbka35vhgkx2vm8mrlw-guile-2.2.6.drv’ is not valid